Resolved
Android was rejecting an SSL certificate that was close to expired (but not expired). This certificate has been renewed.
Identified
There is an issue for android devices connecting when to the login provider, due to security algorithms specific to android. We have identified the issue and are working on a fix.
Investigating
Android app users are currently unable to log in and receive a blank screen after completing log in.