BYO participants experience delays in viewing the studies they have applied for.
Resolved·Degraded performance
A fix has been deployed.
Thu, Mar 5, 2026, 12:56 PM
(1 month ago)
·
Affected components
Participants
Updates
Resolved
A fix has been deployed.
Thu, Mar 5, 2026, 12:56 PM
Identified
Participants who join Askable via a BYO link are experiencing delays viewing the studies they have applied for. We have identified the fault and are working on a fix.
Thu, Mar 5, 2026, 07:02 AM(5 hours earlier)
BYO participants experience delays in viewing the studies they have applied for. - Askable Status