Resolved
PayPal team confirmed their WAF layer blocked our servers' IP. It's now cleared and services started working.
Identified
Our API call to PayPal being blocked by Cloudflare on PayPal side. We have been communicating PayPal to resolve the issue and waiting for their action.
Investigating
Participants failed to receive incentives
Investigating
PayPal linking failure prevents participants to setup their PayPal configuration to receive incentives