Monitoring
Fix is live, monitoring stability.
Identified
We have identified the issue and pushed a fix.
Investigating
We're aware of an issue where some participants opening certain study links were seeing a "This page couldn't be found" error instead of the study. We've identified the cause and a fix is being rolled out. We'll update here once it's live.